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Hot Keys — Schematic

Edit Cdmmands

Following table lists the hot keys for the Edit menu options.

Edit > Copy

Edit > Copy/Paste > Copy Using Reference

Edit > Cut

Edit > Delete .

Edit > End Command

Edit > Mirror About X

Edit > Mirror About Y

Edit > Move > Move Component Text
Edit > Move > Move Edge

Edit > Move > Move Using Reference
Edit > Move > Move Wire Endpoint
Edit > Paste

Edit > Redo

Edit > Rotate

Edit> Undo -

* Help > F1
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Ctri+C
C
Ctrl+X
Del
Esc
Shift+X
Shift+Y
F5

M
Ctrl+Shift+M
Ctrl+Vv
Ctri+Y
Ctrl+R
Ctrl+2

View Commands

Following table lists the hot keys for the View menu options.

View > Clear Highlighting

View > Command Quick Help

View > Grid Display

View > Origin Crosshair

View > Pan View

View > Pop Out Of Hierarchy

View > Push Into Hierarchy

View > Restore Last View

View > View All

View > Zoom > Zoom Area

View > Zoom > Zoom By Factor > Zoom In x2
View > Zoom > Zoom By Factor > Zoom Out x2
View > Zoom > Zoom To Selected

HSD Workshop

F8
Shift+F1
Ctrl+G
Shift+O
Tab

B
Shift+E
Ctrl+L

E

Insert Commands

Following table lists the hot keys for the Insert menu options.

Insert > Change Entry Layer To

Insert > Component > Component Library...
Insert > Measure...

Insert > Shape > Polygon

Insert > Shape > Rectangle

Insert > Shape > Undo Vertex

Insert > Text

Insert > Wire

Ctrl+Shift+C
|

Ctri+M
Shift+P

R
Backspace
Ctrl+T
Ctri+W+ |

Window and Miscellaneous Cor

Following table lists the hot keys for the Window and Miscellaneous

Window > Close

Window > Layout

Window > Open Another Schematic Window
Help > Topics and Index

Options > Snap Enabled

Select > Select All

Simulate > Simulate

Ctrl+F4
Ctrl+Shift+L
Ctrl+Shift+8
F1

Ctrl+E’
Ctri+A

F7




Hot Keys — Data Display

File Command Edit Commands View Commands Miscellaneous Commands
Following table lists the File m Following table lists the Edit menu cor Following table lists the View menu command Following table lists the various other menu commands Sut
- File > New Ctri+N - Edit > Copy Ctrl+C View > Grid Display Ctri+G Help > Topics and Index F1 .
File > Open.... Ctrl+0 Edit > Cut Ctri+X View > Restore Last View Ctri+L Marker > New... - Ctri+M
File > Print.... Ctri+P Edit > Delete Del View > View All F Options > Hide ADS Logo on all plots Alt+L
File > Save Ctri+S | Edit > End Command Esc View > Zoom > Zoom Area Options > Snap Enabled Ctri+E
Edit > Paste Cirl+V View > Zoom > Zoom In x2 + Window > Close Ctri+F4
Edit > Redo Cirl+Y View > Zoom > Zoom Out x2 - Window > New Ctrl+Shift+D
Edit > Select All Ctrl+A
Edit > Undo Ctri+Z

* Help > F1
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\DS Tips Forum (ADS/\##&R) www.keysight.com/find/ADS
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Momentum Overview

 Method of Moment (MoM) technology

« Accurate and efficient simulation of complex multilayer geometries

« Import/draw physical geometry + Define meshing criteria

« S-parameter response
« Verify dielectric stack up & ports * Polygonal mesh is generated - Surface current plots
* Maxwell’s equation solved using  Far field radiation pattern
Method of Moment

Advantages and Applications:

« Tightly integrated within ADS environment

* Design flow integration with ADS tools

» Solves complex 3D multilayer planar geometry
« Fast and efficient simulation

* Accurate from DC up to 100’s of GHz

« Simulate large number of ports

+ PCB, Packages

First version of
Momentum simulator :
Released in 1994

KEYSIGHT Advanced RF Board Skills in ADS
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Benéfit ‘and Cost of MoM Technology

Hybrid
Solver

‘:f]:{[:]ug;: High High

O 3D EM
Learning Easy Normal Hard
Usability Easy Normal  Normal O Mom

Flexibility ~ Low  Medium  High O Hybrid Solver

Speed Fast Medium Slow
Memory - : Accuracy over 10 GHz
Required Low Medium High y

Price Medium  Medium High

KEYSIGHT Advanced RF Board Skills in ADS
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EM Setup Are Different for Each Solver Technology

« FDTD ( Finite Difference Time Domain ) ; Arblran SR SAEC s

e Time Domain
* Full Wave EM Simulations

e FEM ( F|n|te Element Method ) « Handles much larger and complex problems
« Each port requires separate simulation
_ * GPU based hard lerati
* MoM ( Method of Moment ) CEMPrOUL

Today’s Focus

Restricted 3D Structures

Frequency Domain

* Full-Wave and Quasi-Static Simulations

B Dense & Compressed Matrix Solvers
Multiport Simulations at no Additional Cost
* High Q

ADS UI

-
-~ -
pad TP

* Arbitrary 3D structures

* Frequency Domain

* Full Wave EM Simulations
Direct, Iterative Solvers

* Multiport Simulations at no Additional Cost

* High Q

* ADS or EMPro Ul

-~
L]
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EM Ports in MoM Technology

e Consist of + and — terminals

* Placed where EM models connect to circuit
components

« Compute voltages and currents from E&H field, and
also S-parameters

« A lumped source is attached with a source impedance
* No phase delay between + and —terminal
* Must be electrically small (size < 1/10)
» Otherwise it may result unphysical behaviors

KEYSIGHT
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EM Port Calibration in MoM Technology

Direct

TML (Transmission Line)

TML (zero length)

SMD (Surface Mount Devices)
Delta gap

KEYSIGHT
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™, Port Editor

View Edit Tools Help
SHhIDR X WKW T @

S-parameter Forts

Number Gnd Layer Name Feed Type  Ref Impedance [Ohn
v i <Implicit> P1 50 + 0i

Q P1

@ Gnd
v 2 <Implicit> P2 50 + 0i

@ P2

Q@ Gnd
v i3 <Implicit> P3 50 + 0

Q P3

© Gnd v
< >
Layout Fins
Name h Layer Net Connected to f
O P1 cond P1 1(+) q
O P2 cond p2 2(+) e
O P3 cond P3 3(+) o
< >

[] Hide connected layout pins
Anto-select Auto-center | | Auto-zoom

Advanced RF Board Skills in ADS
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General Pin Types

* Correct Pins Allow for Correct Ports

Pin placed anywhere within a geometry,

Point Pin but not on an edge.
Pin placed on any geometry
Edge Pin edge or any explicitly defined
Edge Pin.
Area Pin Explicitly defined Area Pin.

KEYSIGHT
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™, Create Pin X

Term
() By name @ By number

MName |P1 |

Number Type |inCut -




ADS Momentum Port Calibration/Feed Types

- MoM Ports placed on a metal EDGE will excite the entire edge with constant potential. Unless Edge Port is
used to confine excitation. If the edge is >1/10 wavelength results can become non-physical.

« MoM Ports placed inside metal are point sources that will excite a mesh element around the port. Unless Area
Port is used, area becomes constant potential.

 MoM Ports inject current with O deg phase shift (Lumped Source). If the physical difference between the +
and — pins is > 1/10 wavelength results can become non-physical.

* MoM ports, being lumped sources will NOT couple to surrounding structures.

* Port Size restrictions:

Edge Pin Area Pin

KEYSIGHT Advanced RF Board Skills in ADS
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EM Ports Editor

* A Glimpse into Calibration/Feed Types Hover over Feed Type for pop-up help graphic
Port Editor X Feed Type —3 Auto One of the following types auto-
. ) determined by the EM simulalor
View Edit Tools Help Auto -
S PIH® X2 KV 7 @ m
5-parameter Ports Direct
Numbe-/; Gnd Layer Mame Feed Type TML
@ Gnd
v 2 cond2 P2 Auto Delta gap
-+
@ Gnd
L4 >
Layout Pins
MName a Layer Met
O P1  cond p2
O P2 cond p2
KEYSIGHT Advanced RF Board Skills in ADS @ @ @ @e @ 16
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Summary of EM Ports in ADS 2016

* “Old” Nomenclature for Calibration/Feed Type

Calibration Type

Momentum

None

If none of the available calibration types is valid for the connecting component, specify
“None”.

TML
(this is the default, changed @
sim time if not on outer edge)

This calibration type assumes the structure is fed through a transmission line. It removes
the open end effect and adds the mutual coupling induced by the feeding transmission line.

TML (zero length)

This calibration type removes the open end effect.

This calibration type removes the open end effect at port and adds the mutual coupling between the current

SMD flowing from the + to — pins and the rest of the circuit assuming the area between both pins would be filled with
metal.
This calibration type adds the effect of metal filled in the area between the + and — pins. A gap in the middle allows
Delta Gap

connecting the source.

KEYSIGHT
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Summary of EM Ports in ADS 2017 & Newer

 New Nomenclature for Calibration/Feed Type

Feed Type Momentum
Auto This becomes Direct feed 99% of the time. Only TML if placed on outer edge of a slot
plane geometry.
Direct If none of fthe available calibration Feed types is valid for the connecting component,
specify “Direct”.
This calibration Feed type assumes the structure is fed through a transmission line. It
TML removes the open end effect and adds the mutual coupling induced by the feeding

transmission line.

TML (zero length)

This calibration Feed type removes the open end effect.

This calibration Feed type removes the open end effect at port and adds the mutual coupling between the current

SMD flowing from the + to — pins and the rest of the circuit assuming the area between both pins would be filled with
metal.
This calibration Feed type adds the effect of metal filled in the area between the + and — pins. A gap in the middle
Delta Gap

allows connecting the source.

KEYSIGHT
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ML Feed Type (1/5)

KEYSIGHT
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ML Feed Type (2/5)

Fringe Capacitance

KEYSIGHT
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= Port Location
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TML Feed Type (3/5)

Port Location

Added Calibration Line
Length “L"

Source attached

KEYSIGHT Advanced RF Board Skills in ADS
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Port Location
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ML Feed Type (4/5)

Length 2L calibration standard

L
Port Location M

(%2 length 2L)" _
L
-m + [ S ] total = [S ] de-embedded
%mﬂ -1
T : :

KEYSIGHT
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TML Feed Type (5/5)

Aligned Ports Misaligned Ports

Mutual coupling between the feed lines Mutual coupling between the feed lines will
will be removed after TML calibration be turned off during TML calibration

KEYSIGHT Advanced RF Board Skills in ADS
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Ihcorrect Use of TML Feed Type

Port
With
TMLlCaI
' Transmission Line on Layer 1
I
] GND
Sig
Infinite Ground (Cover or Slat)
KEYSIGHT Advanced RF Board Skills in ADS
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Port
With
TI"."ILICaI
Length L Calibration Line | Transmission Line on Layer 1
— Sig
|
| GND
Sig
L &1\ | M)
e 51
GND
Infinite Ground (Cover or Slot)




Ihcorrect Use of TML Feed Type

Port
With
TMLlCaI
' Transmission Line on Layer 1
I
] GND
Sig
Infinite Ground (Cover or Slat)
KEYSIGHT Advanced RF Board Skills in ADS
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Length L Calibration Line ' Transmission Line on Layer 1
Sig
! § Lower Impedance
GND

Higher Im

Sig
pedance
. Sig
GND
Infinite Ground (Cover or Slot)




Ihcorrect Use of TML Feed Type

Port
With
TMLlCaI
' Transmission Line on Layer 1
I
] GND
Sig
Infinite Ground (Cover or Slat)
KEYSIGHT Advanced RF Board Skills in ADS
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Port
With
TI"."ILICaI
Length L Calibration Line ' Transmission Line on Layer 1
Sig
| § Higher Capacitance
GND
Sig
Smaller Capacitance
e 5]
GND
Infinite Ground (Cover or Slot)




TML Zero-Length Feed Type

Relative large
mutual Inductance Port
added from the with

line "L~

TML zero-length cal

L Calibration Line
o Fringe Capacitance is
removed from the calibration

FET FET

KEYSIGHT Advanced RF Board Skills in ADS
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None Calibration - Direct Feed Type

* No port calibration but could be very versatile DUT
Lumped

source 4

« Ground reference can be anywhere

* Applies to point pins, edge pins and area pins

Reference Pin Reference Pin

« Some guidelines -
 Port size must be electrically small (length < A1/10) ()
« Ground reference should be on the true ground return path _
- Alocal open end effect is included in the DUT model. This is Ly Reference Pin

a result of the direct feed being applied to the edge port.

KEYSIGHT
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Delta-Gap Feed Type

Ideal Cap
| |
11
Gap
| |
11




Delta-Gap Feed Type

Delta Gap Mutual, to ground and nearby traces

Extended Pad Extended Pad

Self Inductance Self Inductance

Capacitance to Grounds Capacitance to Grounds

KEYSIGHT Advanced RF Board Skills in ADS
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SMD Feed Type

Mutual, to ground and nearby traces

4
-Calibrated

Calculation is referenced to the infinite ground plane

i
5

Calibrared
- Seff{rductance

-Self Induetance- {1

)
)
)

Cahbmed—‘eapamanceioemunds > Capacitance-te Grounds -

Calibrated

Calculation is referenced to the infinite ground plane

KEYSIGHT

Advanced RF Board Skills in ADS
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Both of Delta-gap and SMD Feed Type

- Only differential mode supported  Current flows straight through the added pads

KEYSIGHT Advanced RF Board Skills in ADS
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Lab1 _ Port Calibration/Feed Types

> Long line with gap for SMD component
» Gap port calibration = DeltaGap|SMD|None(Direct)
» Gap shorted

Through Line

Port Feed Type = Direct
Port Feed Type = SMD

Port Feed Type = Delta-Gap

KEYSIGHT Advanced RF Board Skills in ADS
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Lab1 — Port Calibration/Feed Types

> Long line with gap for SMD component
» Gap port calibration = DeltaGap|SMD|None(Direct)

KEYSIGHT
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» Quick review of Momentum
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» Lab2: Net Type Setup for Physical Model Simplified
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Metal Model Types

| fdiel2] h,
r) ,&z,l.lg
~ [diet2] h,,&.1, 'ﬂ‘f’ [ Tnew] I 8,
* Sheet-Sheet I
(diel1] b8 (diel1] h,, 8,1,
ud IntrUde/ EXpand'ShGEt : Y s
* Intrude/Expand-2D distributed ] |
- e [diel2) Th,em,  Intrude | (de Th, &,
e Intrude/Expand-3D distributed (Recommended) I R N et . T Mot
- (diet1] i,.wJ (dief1] h,.&.u, ‘
VL iyt Vs,
. — @ Eheet
5= - -gu_rg?" Jparabion ':' Tnirnde inio subsiate
- - Bapand the substoate Model type for currents
Thick conductor
Via 2D-dsstributed
. 1 ) Sheet 3D-distributed
i il Crparation 0 Intrnds dnte substrats ' ! ! o '
@ Escpand the substrate )
(il
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Thick Metal Model Types

Sheet

- Top and bottom currents collapsed
- No sidewall currents

2D distributed

- Top and bottom currents separate
- Vertical sidewall currents only

3D distributed(Recommended)

- Top, bottom and sidewall currents separate
- Any surface current

KEYSIGHT Advanced RF Board Skills in ADS
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Controlled Impedance Line Designer (CILD)

' . | 35 i1 (L1 i * (Cormroied bmpeciarcs Line Desier] = =
 Impedance Calculation e — -
CLEEY XTI Y
» Width Calculation for specific impedance s -
* Support Strip, Microstrip, CPW, Single-Ended, 1 R
Differential Pair Types A L

» Statistical Calculation

o | Thow Lo T Wik i W Bobelik Yo Sl Edikriad Var

* Model Generation o T | e

Tvpr Elnpow Smgls-Ewded

Teoppem g2
sl :p:3
Beotkom ol [l
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Check TDR of Metal Type
Accuracy: 3D+Edge > 3D > 2D >> Sheet

I -l il o

3000 mil Single Ended Tline

g Few TEoERaly INEEEE SR
TEH @ 9T LA e
& B vhm L Chdrm
e =
ey s 95
- . - = H
Ca— ol S I 53 \
I ) A
S s14—§/ A
e e o wwom L g = ‘--.“ Ll 5
T T e " Il.'I.la..._._ i [} "9'-'
Torn Bl T age-fiened - ,n"'_.-l-"‘\l_'-' E B
Iy g [h—~ Com ) E 47—
Famal e — .-|
e
Dy e GRS ] 45 TTTT'I'TTTTTTTTTTTTTT'I'TTTT
ey S 3.000n 3400n 3.800n 4.200n 4.600n 5.000n
——— time, sec |
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Via Modeling

Lumped -
(Recommended for
Power/Ground vias)

- DG resistance and skin effect
- Wira self inductanca
= Mezhless equivalent circuit

- DC resistance and skin efect

- Wire salf inductance

= Mutual wire-wire and wire-infinite ground inductances
- Meshless equivalent circuit

Wire

2D-Distrubuted |
(Recommended for
TLine vias)

- DC resistance and skin sffect
- All self and mutual inductances and capacitances
- \ertical sidewall currents anly

- DC resistance and skin efect

=i - All =elf and mulual inductances and capacitances
3D-Distrubuted Any aircs
KEYSIGHT Advanced RF Board Skills in ADS @ @ @ @@ @ 40
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RFPro Vision: EM for every RF circuit designer

Allows users to focus on design rather than setting up EM

* Integration
o/ 3D view

Solution for RF PCB, RFIC, MMIC
and RF Modules

‘/ Enhanced ADS MOM and FEM
simulator performance

* Solver

* Layout

/Automatic EM expert settings ./ No Cookie cutting

guarantee confidence in EM results

for novice and expert users

o/ No exporting

 Fast & correct analysis setup for / No removing active devices and

EM-circuit co-simulation

.....

placing pins & ports

J No reconnecting schematics
to s-parameter files

RF Module

KEYSIGHT
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RFPro Momentum: Automatic Mode for Vias/Thick Metals

» Thanks to RFPro platform, Momentum can now automatically apply different via/thick conductor
models depending on the nets type : signals, grounds and power planes

Physical model
Thick conductor model Automatic
Via conductor model Automatic

Example on a 60 GHz Wilkinson divider

| RFPro2020 RFPro 2020U1

Matrix size 127500 4750
Runtime (MomRF) > 10h 27mn

KEYSIGHT
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Lab2 - Net Type Setup for Physical Model Simplified

Panda Board

°
- FM_ANT RX =
o M R4
s M—A N T—I N e FIDRILL_TOP BOTIOM. [JDRILL_TOP LYRZSIG [JDRIL_TOP LY3-GAD (1.2 el
2 g H 251G
_ sa—H | . FRA4 (45
 Frequency Range e i
» 0~500 MHz o= : s
i1 = 4315 -
356 ; FR4 49
e _i o 4 O 4 : ﬁgwﬂl
8 :g —EICH_LYRG-PWE | .ﬁg i
s2b—1 ' Fra @5
H CTECH_LYRTSG (8412 il
Il =TT BOTION AR
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Simulation Result with Automatic Physical Model

e Thick Conductor Model Summsry | Log X Auto-scroll [ Update ] |

Starting Momentum simulation.
° Automatlc St.El.lril:.ing C:\Pll:ogra.m Files\Reysight\ADS2020 update2\Momentumh2020.20\win32 &4\bin\MomEngine.ecxe
Waiting for license...
License checkout took 4 min, 0.326 sec
Y Via Conductor Model License checkout took 0.033 s=c
Momentum MomEngine €4 2020.20.064 (*) built: Feb 13 2020
: Copyright 19%2 - 2020 Eeysight Technologies
y AUtomatIC Simulation started on: Mon Zpr & 09:37:37 2020
Simulation Mods: RF
Substrate wvalid
Layout simplification started
Layout simplification finished
Generating mesh at 500 MH=...
S-parameter simulation
S-paramster simulation started
«..initializing
-..extracting layout
...expanding thick conductors
Layout is electrically small below 1.15 GHz (space wave radiation)
Substrate is slectrically small below 9.9%98 GHz (surface wave radiation)
.. .reducing mesh
Zutomatic selection: direct compressed matrix solver
Using multi-threading (8 threads)
Matrix size: 21433 (reduced: 7054)
Simulation temperaturs: 298.15 E
Ldaptive frequency sweep started
Simulation fregquency [1] = 0 H=
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Simulation Result with Manuel Physical Model

X Autoscroll | Update | | 1

* Thick Conductor Model Sunmary | Log

Starting Momentum simulation.
° :3[) Starting C:\Program Files\Reysight\ADS2020 update2\Momentum\Z020.20\win32 E4\bin\MomEngine.sxe
License checkout took 0.0%8 sec
. License checkout took 0.032 sec
* Via Conductor Model Momentum MomEngine 64 2020.20.064 (*) built: Feb 13 2020
Copyright 1952 - 2020 Reysight Technologiles
° 2D Simulation started on: Mon Zpr € 09:44:35 2020
Simulation Mode: RF
Substrate wvalid
Layout simplification started
Layout simplification finished
Generating mesh at 500 MH=. ..
S-paramster simulation
S-parameter simulation started
...initializing
...extracting layout
--..expanding thick conductors
Layout is electrically small below 1.15 GHz (space wave radiation)
Substrate is electrically small below 9.98 GHz (surface wave radiation)
...reducing mesh
Automatic selection: direct compressed matrix solver
Using multi-threading (8 threads)
Matrix size: 14670 (reduced: 3501)
Simulation temperature: 2%8.15 K
2daptive frequency sweep started
Simulation fregquency [1l] = 0 Hz
...loading Green functions

KEYSIGHT
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Simulation Result with Different Net Type

1. Set D _GND net type as GND
2. Set D_GND net type as PWR
3. Set D_GND net type as SIG

KEYSIGHT

TECHNOLOGIES

SUMLMALy Log X Auto-scroll L

Starting Momentum simulation.

Starting C:\Program Files\FKeysight\ADS2020_ update2\Momentumi202(
Waiting for license...

License checkout took 4 min, 0.326 sec

License checkout took 0.0332 sec

Momentum MomEngine €4 2020.20.064 (*) built: Feb 13 2020
Copyright 19%%2 - 2020 Eeysight Technologies

Simulation started on: Mon Apr & 05:37:37 2020 omentum\2020.20\
Simulation Mods: RF X An
Substrate wvalid e
Layout simplification started
Layout simplification finished
Generating mesh at 500 MH=z...
S-parameter simulation
S-parameter simulation started 13 202
...initializing

...extracting layout

...expanding thick conductors

Layout is electrically small below 1.15 GHz (space wave radiatic

Substrate 1s electrically small kelow 9.%8 GHz (surface wave rac

. ..reducing mesh

Zutomatic selection: direct compresssed matrix solwer

Using multi-threading (8 threads)

Matrix size: 21433 (reduced: 7054) ]_ ave radiation)
Simulation temperatures: 25§.15 K ace wave radiati
Ldaptive frequency sweep started

Simulation fregquency [1] = 0 Hz

2020
2\ Mome:

Using multi-threading (8 threads)
Matrix size: 21433 (reduced: 7054) 22
Simulation temperature: 29%8.15 E iarface
Adaptive fregquency sweep started

Simulation frequency [1] = 0 H=z TeT

= wWawve

Tom e e SR TMGTIE1I-Threading (¢ TArsads)
Matrix size: 192893 (reduced: 715€8) 53
Simulation temperaturs: 298.15 K
Ldaptive frequency sweesp started
Simulation frequency [1] = 0 H=z




Outline

» Quick review of Momentum

» Labl: Port Type Overview

» Lab2: Net Type Setup for Physical Model Simplified
« Lab3: Understand Mesh, Solver and Preprocessor

e Summary
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Mesh in RFPro

G RFPro Setup - Advanced Simulator Setup

stmulator: Momentum EF
Global | Overrides
=-:Solver
- Matrix solver Automatic
= Mesh
Mesh density 20 cpw
Geometry overlap extraction  Normal
Edge mesh Off
Mesh reduction On
& Physical model
b Thick conductor model Automatic
o Via conductor model Automatic
= Preprocessor
------ Healing snap distance Automatic
----- Simplify layout On
------ Ignore conductor shapes Automatic
----- Ignore conductor holes Automatic
(] g
Eevert Zancel ;
A
555%%[90'11 Advanced RF Board Skills in ADS @ @ @ @@ @ 48




Momentum Mesh Generator

 Layout conforming meshes with quadrilateral, rectangular
and triangular cells used to compute currents
Bi(n) Bz(r) Ba(r)
i I 2
31 52
» MoM problem can be mathematically thought of '
as a 3D equivalent circuit network with PN .
frequency-dependent R’s, L’s, and C’s i ‘L
» An impedance matrix is created and then solved ”c,.—- - €22
that allows us to obtain the current amplitudes v "\ Gz A v
based on the excitations at the ports Z1.111=
» Create matrix = Matrix Load (quadruple integrals [ ][ ]_ [V]
over surfaces of all cell pairs) o S
o [STL

KEYSIGHT
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Edge Mesh

« 1 - Port
» 2 - Mesh
. 3 - Edge Mesh

KEYSIGHT
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Geometry Overlap Extraction

« Thin Layer Overlap

* If two drawing layers are separated by a thin substrate layer and the mesh cells and object
boundaries are not aligned correctly, the simulation data may be less accurate

KEYSIGHT
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FEM Generation 2 : Mesh-domain optimization

Mesh-domain optimization in Momentum is coming soon.

* In case of large ground or power planes,
the simulation space might still be too

Initial Mesh

- Generation Generation 2 |arge tO be eff|C|ent
- Target Mesh Size Automatic
Off -
-~ Conductor Edge Mesh Le...
“ Minimum Mesh Size Off
Adaptive Refinement <Inherit from preset>

« ADS 2020 Update 1.0 Mesh Domain
Optimization to reduce the simulation
space with 2 constraints
« Much more stable than a cookie cut

The mesher
automatically optimizes
the domain to suppress
parts where the field is
neglectable

- Automatically adapts for several critical -
nets to be simulated in series

» No need to multiply layout views for each
cookie cut

KEYSIGHT
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Solver in RFPro

G§ RFPro Setup - Advanced Simulator Setup

simulator: Momentum EF

| Global | Overrides

= Solver

Matrix solver

= Mesh

Mesh density

Geometry overlap extraction
Edge mesh

Mesh reduction

hysical model

Automatic - I

Direct-dense
lterative-dense
Direct-compressed
<Inherit from preset>

----- Thick conductor model Automatic
------ Via conductor model Automatic
= Preprocessor

------ Healing snap distance Automatic
----- Simplify layout On

------ Ignore conductor shapes Automatic
----- Ignore conductor holes Automatic

Al | )

KEYSIGHT
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Solver in RFPro

« MoM technology chooses automatically the best solver for your application

(6 ;
= CPUtime=A+BN+CN2+DN3
= Direct Solver where:
g O(N"3) O_(NA 2) N = number of unknowns
= Iterative Solver The constant term A accounts for the simulation set up time.
© The meshing of the structure is responsible for the linear term, BN.
g % O(N o N) The loading of the interaction matrix is responsible for the quadratic
= Direct comg ressed term and the solving of the matrix equation accounts for:
N P * Part of the quadratic term (when using the iterative solver)
* The cubic term (when using the direct solver
~2-3000 Unknown currents (N) ( | )
o Q0000




Preprocessor in RFPro

G RFPro Setup - Advanced Simulator Setup

stmulator: Momentum EF
Global | Overrides
=-iSolver
- Matrix solver Automatic
[=p MESh
------ Mesh density 20 cpw
----- Geometry overlap extraction  Normal
------ Edge mesh Off
----- Mesh reduction On
= Physical model
----- Thick conductor model Automatic
------ Via conductor model Automatic
= Preprocessor
Healing snap distance Automatic
Simplify layout On
Ignore conductor shapes Automatic Ignore (remove) conductor shapes up|to a width or height of 5 microns.
Ignore conductor holes Automatic Ignore (fill) conductor holes up to a width or height of 5 microns. -
<] D
Eevert Cancel

KEYSIGHT
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Layéut Healing

« Closes unintentional gaps between adjacent * Merge

shapes

 Ensures that stacked vias have only one joint

-

boundary

{

“+-

e Snap

- Eliminates acute angles

KEYSIGHT
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Layout Simplification

 Layout simplification is required to reduce number
of meshes without loss of accuracy

shape 1

KEYSIGHT

TECHNOLOGIES

Simulation Options

Freset: |Default ' Rename. ..

Description Physical Model Preprocessor Mesh Solver Expert
Global: All Shapes Global: Patterns Layver Specific

show Wisual Aid

Eemove

Heal the lagout
nearby edges and vertices will be snapped together

® Auto-determine a safe snap distance (conservative)

() User specified snap distance: [ mil =

D Merge shapes tonching each other where possible
shared edges in the mesh will not be preserved

Simplify the lavout
vertex count will be reduced, without changing the topology
Constraints (upper limits)

Displacement % of the wavelength -
Shrinkagefgrowth % or arc resolntion degrees

[[] Use different constraints for wias
Displacement |1 % of the wavelength
Shrinkagefgrowth (7.6 % or arc resolution |43 degrees
[] Mever change lines whosa length exceeds 0

il

[ ] lsnore shapes on the following purposes:
dummy dommy2




Guidance RFPro Setup for IC Design

Reasonable defaults for IC Designs:

Mode: MomRF (switch to MomMW if status window indicates electrically large design)

Ports: ‘Auto’/'Direct’ for most ports, TML only if intend design to be included in context with same
transmission line widths at those port locations.

Frequency plan: include DC in frequency plan

Output Plan: only save currents if necessary for post-processing visualization (also uncheck ‘Reduce to
decrease size’ in Model options if you do wish to visualize currents)

Physical Model: 3D-distributed thick conductor model, 2D-distributed/Wire via model for most (3D
Distributed for via in RF path)

Preprocessor: displacement=0.1 um or auto, arc resolution = 5 degrees for arcs, 45 degrees for vias, use
via merge options and/or metal fill options (when needed)

Mesh: mesh density 200-1000 cells @ highest frequency, edge mesh (on for sheet conductors, off for thick
conductors), thin layer overlap extraction (Normal for MIM caps, off otherwise), consider Layer Specific
meshing if need finer/coarser mesh on specific layer(s)

Solver: if using ‘Auto-select’ or ‘Direct Compressed’ (‘Direct Dense’ guarantees highest accuracy, at

potential cost of more RAM and sim time)
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Guidance RFPro Setup for Laminate/PCB

Reasonable defaults for Laminate/PCB Designs:

Mode: MomRF (switch to MomMW if status window indicates electrically large design)

Ports: ‘Auto’/'Direct’ for most ports, TML only if intend design to be included in context with same
transmission line widths at those port locations.

Frequency plan: include DC in frequency plan

Output Plan: only save currents if necessary for post-processing visualization (also uncheck ‘Reduce to
decrease size’ in Model options if you do wish to visualize currents)

Physical Model: 3D-distributed thick conductor model, 2D-distributed/Wire via model for most (3D
Distributed for via in RF path)

Preprocessor: displacement=1 um or auto, arc resolution = 5 degrees for arcs, 45 degrees for vias
Mesh: mesh density 20-60 cells @ highest frequency, edge mesh (on for sheet conductors, off for thick
conductors), thin layer overlap extraction off, consider Layer Specific meshing if need finer/coarser mesh on
specific layer(s)

Solver: if using ‘Auto-select’ or ‘Direct Compressed’ (‘Direct Dense’ guarantees highest accuracy, at

potential cost of more RAM and sim time)

KEYSIGHT
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Momentum RF vs. Momentum Microwave

* Physical structures radiate into free space (spherical
waves) and into substrates (cylindrical waves)

 Radiation for electrically small structures is very small
« MomRF mathematically eliminates radiation

« Computes quasi-static Green’s functions at a low
frequency

« High accuracy possible even at very high frequencies
(100 GHz or more) — just depends on electrical size of

structure

» Approximate frequency limits are reported in the log
file

KEYSIGHT
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Space & Substrate Radiation

.
o3

S-parameter simulation
S-parameter simulation started
initializinuT

Layout i=s electrically =mall below 18.4 GHz |(space wave radiation)
Substrate is electrically =mall below 8.05 GHz (surface wawve radiatiomn)

]

i

Automatic selection: direct dense matrix solver
Using multi-threading (2 threads)

Bdaptive frequency sweep started

Simunlation frequency [1] = 0 Hz




Lab3 - RFPro EM-cosimulation
Two-Stage RF Board Amplifier with SMT Components

[ Advanced Design System 2019 (Main) — O X

File View Options Tools Window DesignKits DesignGuide Help

wiv Be WED>W=%

File View Folder View Library View

A 2-stage LNA built on a 2-layer board.

SMT components (transistors, capacitors, inductors, s
éﬁ emiCosim

resistors) are from a board design kit, all have 20 emseup
component models.

Interconnect lines are Layout based and will be
simulated with EM.

There are 4 ports (8 pins)
« 2 pins RFin (Signal, Gnd)

» 2 pins RFout (Signal, Gnd)
* 2 pins VDC1 (Power, Gnd)
» 2 pins VDC2 (Power, Gnd)

vDC1 vDC2 H
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Three Main Steps to RFPro

3- Setup the simulation

2- Drag down Pins frequency anciel

Simulatorin “Options”
Start RFPro from Layout page D

5 \* Full EM Analysis
:) Ports
= Component Models

into analysis section =7
[Fo_Stage_Amp:layout] (Layout):T f:_ Iyses
Options  Tools Schematic EM Window DesignGuide Help to form Ports & [em| Full EM Analysis
) QU™ oec. =AY @0 Ports
) - O To I Design -3
=F #  DRC Results Viewer... A RF_Board_lib:Two_Stage_Amp:lay... =] _"\‘ Component Models
= Set Connectivity Options... 1 . . 3 o Nets T & " C (Board_Desi Kit:
- |_Design_Kit:C)
EM| o Check Connectivi > - Dra down Cerl.“t 3 (€ Components T r; .
e g 5 B Substrate @ HBFP-0420 (Board_Design...
;f C-ontrol.led Impedance Line Designer mOd el Com ponents O Pins 'Y ‘.K] L (Board_Design_Kit:l.)
= Via Designer O+ P1zRFin ) R (B d Desi Kit R)
b H H H - |2 oard_Design_Kit:
g R [ into analysis section OF Faxoud ; U
SIPro/PIPro > O+ P3 = RFout
O+ P4:Gnd
B2  Check Design... — Os P5=VDC1 ‘:_9) Run
eé DS Desidop LN < 5 & csp O« P6:Gnd EH 7 Results
Check Design Report... 3 JF C7.P2 O+ P7=VDC2 -y
S-Parameters
Calibre LVS » 5 dF cap1 O+ P8=Gnd e
. > ¥ oo ‘ e f TOR/TOT
acro G Qi1 2 oo
5 & Q192 i Detlons WA Generate Test Bench...
Hierarchy... 5 JF Q2P1 8 ¥ Matenals il . .
o o ) e Rociaaanad. . w# Generate Sub Circuit...
S € Components T «| ;‘ SCl’iptS
o
% o RFPro &x
=1 . .
2 - per® Run simulation
=} D & Substuvle .) Ports
5 Or Pins -
() O :“.m, Pins - “ Component Models 5 mi
% 3 Deﬂnibons = 'k“ C (Board_Design_Kit:C) 30—
o 1D = 25
% 9‘; 20—
3 —
o
o
@
(2]

dB(S(2,2))
dB(S(1,1)
dB(S(2.1))

o0
‘ﬂ- Options...

5
10
& Run .
9 = Results -15]
5 o~ = -
. o T v T T
=

freq, GHz
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Outline

» Quick review of Momentum

» Labl: Port Type Overview

» Lab2: Net Type Setup for Physical Model Simplified
» Lab3: Understand Mesh, Solver and Preprocessor

e Summary
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Summary

« This Webinar help users to understand the port type (calibration type), physical model, mesh,
solver and preprocessor setting of MoM technology (Momentum) in RFPro.

* There are different factors having to be taken into account when modeling. User have to
understand the difference between condition to get accurate results. It is important to seek balance
between cost and accuracy.

* ADS RFPro not only can do EM & Circuit co-simulation easily, but also check TDR/TDT
Impedance, near-field, far-field directly. It's a useful tool for users to analyze simulation quality.
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